enable horde webmail to display html (and multi-part) messages inline

Did your users complain, that they can’t open emails with html content in them? Are those users using your Horde installation? 😉

This problem occurs due to the default setting in Horde Webmail, which is justifyable: Displaying HTML content and images opens the door for SPAM and potentially even malware. So, I’d even go so far and say it is a good default. But we all want to make our users happy, right? So how do we go about this?

Easy: Look at the documentation here -> http://www.horde.org/apps/imp/docs/INSTALL

Then stop and think: “shoot, I have a Plesk machine that might override the settings at every reload of domain.” 😦
Ok – I’ve been there. Here’s my (admittedly imperfect) solution:

  • create a file called mime_drivers.local.php in /etc/psa-webmail/horde/imp
  • put the following content in:
<?php
$mime_drivers['html']['inline'] = true;
?>
  • make a link to that file in /usr/share/psa-horde/imp/config
  • done

I can’t guarantee, that this will last beyond the next server reconfig, but for now my users are happy. 😉

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s